Errors trying to install Spokestack on iOS w/ React Native

Hello!

I’m new to using Spokestack and wanted to add it to my React Native project. Unfortunately, I’ve gone through the installation multiple times and always run into this error:

An unexpected error was encountered. Please report it as a bug:
CocoaPodsError: Command pod install failed.
└─ Cause: pod exited with non-zero code: 1
at CocoaPodsPackageManager._installAsync (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:92213)
at processTicksAndRejections (internal/process/task_queues.js:97:5) {
code: ‘COMMAND_FAILED’,
cause: Error: pod exited with non-zero code: 1
at ChildProcess.h (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:1073)
at Object.onceWrapper (events.js:421:26)
at ChildProcess.emit (events.js:314:20)
at maybeClose (internal/child_process.js:1022:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:287:5)

at Object.spawnAsync [as default] (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:558)
at CocoaPodsPackageManager._runAsync (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:92995)
at CocoaPodsPackageManager._installAsync (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:90499)
at CocoaPodsPackageManager.installAsync (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:90187)
at runAsync (/Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:106206)
at processTicksAndRejections (internal/process/task_queues.js:97:5)
at async /Users/jhiaturner/.npm/_npx/4320/lib/node_modules/pod-install/build/index.js:2:106284 {
pid: 4327,
output: [ ‘’, ‘’ ],
stdout: ‘’,
stderr: ‘’,
status: 1,
signal: null
},
isPackageManagerError: true
}

I’m not sure what it is, but the error says to report it as a bug. Can anyone help with this?

Thanks!

Hi JT, thanks for using Spokestack!

I’m sorry to hear that you’re having trouble installing Spokestack in React Native via CocoaPods. Unfortunately the error you posted just refers to CocoaPods, without any clue if there’s an underlying error in Spokestack or any other pod. You’ll have to refer to Cocoapods support to start unwrapping what’s happening. I suggest starting at CocoaPods Guides - Troubleshooting. The first step to that is usually to examine the contents of your Podfile, which if you post here I can take a quick look and see if anything stands out.